You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/ethloop/ethloop-10-r4.ebuild

29 lines
570 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Local simulator for testing Linux QoS disciplines"
HOMEPAGE="http://luxik.cdi.cz/~devik/qos/ethloop/"
SRC_URI="http://luxik.cdi.cz/~devik/qos/${PN}/${PN}${PV}.tgz"
S="${WORKDIR}"/${PN}
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
RESTRICT="mirror bindist"
PATCHES=(
"${FILESDIR}"/${P}-misc.patch
)
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_install() {
dosbin ethloop
}