You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/odhcploc/odhcploc-20111021-r2.ebuild

32 lines
564 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Open DHCP Locator"
HOMEPAGE="https://odhcploc.sourceforge.io"
SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64"
DEPEND="
elibc_musl? ( sys-libs/queue-standalone )
"
src_configure() {
# Don't clobber toolchain defaults
sed -i -e 's:-Wp,-D_FORTIFY_SOURCE=2::' Makefile || die
tc-export CC
}
src_install() {
dobin ${PN}
doman ${PN}.8
dodoc AUTHORS
}