You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/pathload/pathload-1.3.2-r1.ebuild

32 lines
653 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Non-intrusive utility for estimation of available bandwidth of Internet paths"
HOMEPAGE="https://www.cc.gatech.edu/fac/constantinos.dovrolis/bw-est/pathload.html"
SRC_URI="https://dev.gentoo.org/~jsmolic/distfiles/${P}.tar.gz"
S="${WORKDIR}/${P/-/_}"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
PATCHES=(
"${FILESDIR}"/${P}-make.patch
"${FILESDIR}"/${P}-clang16.patch
)
src_configure() {
tc-export CC
default
}
src_install() {
dobin ${PN}_snd ${PN}_rcv
dodoc CHANGELOG CHANGES README
}