You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/shodan/shodan-1.30.0.ebuild

37 lines
819 B

# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="The official Python library for Shodan"
HOMEPAGE="https://github.com/achillean/shodan-python"
MY_PN="${PN}-python"
if [[ ${PV} = "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
else
inherit pypi
KEYWORDS="amd64 ~loong x86"
fi
LICENSE="MIT"
SLOT="0"
RDEPEND="
dev-python/click[${PYTHON_USEDEP}]
dev-python/click-plugins[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
>=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
dev-python/tldextract[${PYTHON_USEDEP}]
dev-python/xlsxwriter[${PYTHON_USEDEP}]
"
# Test requires API key
RESTRICT="test"