You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/siphon/siphon-666-r2.ebuild

35 lines
659 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
MY_P=${PN}-v.${PV}
DESCRIPTION="A portable passive network mapping suite"
HOMEPAGE="http://siphon.datanerds.net/"
SRC_URI="http://siphon.datanerds.net/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
DEPEND="net-libs/libpcap"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-log.patch
"${FILESDIR}"/${P}-fno-common.patch
)
src_compile() {
emake CC="$(tc-getCC)"
}
src_install() {
dobin ${PN}
insinto /etc
doins osprints.conf
dodoc README
}