You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/snallygaster/snallygaster-0.0.12-r2.ebuild

26 lines
632 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9,10,11,12} )
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Finds file leaks and other security problems on HTTP servers"
HOMEPAGE="https://github.com/hannob/snallygaster"
LICENSE="CC0-1.0"
SLOT="0"
KEYWORDS="~amd64"
DEPEND="dev-python/dnspython
dev-python/urllib3
dev-python/beautifulsoup4"
RDEPEND="${DEPEND}"
DOCS=( README.md TESTS.md )
# Only codingstyle and similar tests, require dependencies
# not packaged in Gentoo
RESTRICT="test"