You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-dns/dnstop/dnstop-20140915-r3.ebuild

40 lines
734 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit autotools flag-o-matic
DESCRIPTION="Displays various tables of DNS traffic on your network"
HOMEPAGE="https://github.com/measurement-factory/dnstop"
SRC_URI="http://dns.measurement-factory.com/tools/dnstop/src/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm ~hppa ppc x86"
RDEPEND="sys-libs/ncurses:0
net-libs/libpcap"
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${P}"-pkg-config.patch
"${FILESDIR}/${P}"-musl-fix.patch
)
src_prepare() {
default
eautoreconf
}
src_configure() {
append-cflags -D_GNU_SOURCE
econf --enable-ipv6
}
src_install() {
dobin dnstop
doman dnstop.8
dodoc CHANGES
}