You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-dns/openresolv/openresolv-3.12.0-r1.ebuild

44 lines
1.1 KiB

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="A framework for managing DNS information"
HOMEPAGE="https://roy.marples.name/projects/openresolv"
SRC_URI="https://roy.marples.name/downloads/${PN}/${P}.tar.xz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="selinux"
RDEPEND="!sys-apps/systemd[resolvconf]
selinux? ( sec-policy/selinux-resolvconf )"
src_configure() {
local myeconfargs=(
--prefix="${EPREFIX}"
--rundir="${EPREFIX}"/var/run
--libexecdir="${EPREFIX}"/lib/resolvconf
)
econf "${myeconfargs[@]}"
}
pkg_config() {
if [[ -n ${ROOT} ]]; then
eerror "We cannot configure unless \$ROOT is empty"
return 1
fi
if [[ -n "$(resolvconf -l)" ]]; then
einfo "${PN} already has DNS information"
else
ebegin "Copying /etc/resolv.conf to resolvconf -a dummy"
resolvconf -a dummy </etc/resolv.conf
eend $? || return $?
einfo "The dummy interface will disappear when you next reboot"
fi
}
DOCS=( LICENSE README.md )