You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/NativeThread/NativeThread-0_pre20190914-...

43 lines
736 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit flag-o-matic java-pkg-2 toolchain-funcs
DESCRIPTION="NativeThread for priorities on linux for freenet"
HOMEPAGE="https://github.com/hyphanet/contrib/blob/master/README"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~x86"
CDEPEND="
dev-java/jna:4
"
DEPEND="net-p2p/freenet
>=virtual/jdk-1.8:*"
RDEPEND=">=virtual/jre-1.8:*"
S="${WORKDIR}"
PATCHES=(
"${FILESDIR}/${P}-javah.patch"
)
src_prepare() {
default
}
src_compile() {
append-flags -fPIC
tc-export CC
emake
}
src_install() {
dolib.so lib${PN}.so
dosym lib${PN}.so /usr/$(get_libdir)/libnative.so
}