You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/libiscsi/libiscsi-1.18.0.ebuild

47 lines
908 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
inherit git-r3
else
SRC_URI="https://github.com/sahlberg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ppc64 ~sparc x86"
fi
DESCRIPTION="iscsi client library and utilities"
HOMEPAGE="https://github.com/sahlberg/libiscsi"
SLOT="0"
LICENSE="GPL-2 LGPL-2"
RDEPEND="dev-libs/libgcrypt:0="
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-fno-common.patch
"${FILESDIR}"/${P}-fno-common-2.patch
"${FILESDIR}"/${P}-fno-common-3.patch
)
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
--enable-manpages \
--disable-static \
--disable-werror
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}