You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/libnet/libnet-1.2.ebuild

32 lines
904 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="library providing an API for commonly used low-level network functions"
HOMEPAGE="http://libnet-dev.sourceforge.net/ https://github.com/libnet/libnet"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="BSD BSD-2 HPND"
SLOT="1.1"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="static-libs"
DOCS=(
ChangeLog.md README.md doc/MIGRATION.md
)
# This patch is taken from master branch in mainstream commit a1659e2. It is
# necessary in order to support musl libc.
PATCHES=( "${FILESDIR}/${P}-int64_t.patch" )
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
find "${D}" -name '*.la' -delete || die
}