You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/libomemo/libomemo-0.8.1-r1.ebuild

39 lines
675 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake
DESCRIPTION="Implementation of OMEMO (XEP-0384) in C"
HOMEPAGE="https://github.com/gkdr/libomemo"
SRC_URI="https://github.com/gkdr/libomemo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
RDEPEND="
dev-db/sqlite
dev-libs/glib
dev-libs/libgcrypt
dev-libs/mxml:0
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
test? ( dev-util/cmocka )
"
RESTRICT="!test? ( test )"
DOCS=( CHANGELOG.md README.md )
src_configure() {
local mycmakeargs=(
-DOMEMO_WITH_TESTS=$(usex test)
)
cmake_src_configure
}