You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/libslirp/libslirp-4.6.1.ebuild

36 lines
830 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit meson
KEYWORDS="amd64 arm64 ~m68k ~ppc ppc64 ~riscv x86"
MY_P="${PN}-v${PV}"
SRC_URI="https://gitlab.freedesktop.org/slirp/libslirp/-/archive/v${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="A TCP-IP emulator used to provide virtual networking services"
HOMEPAGE="https://gitlab.freedesktop.org/slirp/libslirp"
LICENSE="BSD"
SLOT="0"
IUSE="static-libs"
RDEPEND="dev-libs/glib:="
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
src_prepare() {
echo "${PV}" > .tarball-version || die
echo -e "#!${BASH}\necho -n \$(cat '${S}/.tarball-version')" > build-aux/git-version-gen || die
default
}
src_configure() {
local emesonargs=(
-Ddefault_library=$(usex static-libs both shared)
)
meson_src_configure
}