You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/libsmi/libsmi-0.5.0-r1.ebuild

35 lines
913 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="A Library to Access SMI MIB Information"
HOMEPAGE="https://www.ibr.cs.tu-bs.de/projects/libsmi/"
SRC_URI="https://www.ibr.cs.tu-bs.de/projects/libsmi/download/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="static-libs"
RESTRICT="test"
src_configure() {
econf $(use_enable static-libs static)
}
src_test() {
# sming test is known to fail and some other fail if LC_ALL!=C:
# https://mail.ibr.cs.tu-bs.de/pipermail/libsmi/2008-March/001014.html
sed -i '/^[[:space:]]*smidump-sming.test \\$/d' test/Makefile
LC_ALL=C emake -j1 check
}
src_install() {
default
dodoc ANNOUNCE ChangeLog README THANKS TODO \
doc/{*.txt,smi.dia,smi.dtd,smi.xsd} smi.conf-example
find "${ED}" -name '*.la' -delete || die
}