You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/tox_extension_messages/tox_extension_messages-0.0....

25 lines
537 B

# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
DESCRIPTION="Tox Extension Messages"
HOMEPAGE="https://github.com/toxext/tox_extension_messages"
SRC_URI="https://github.com/toxext/tox_extension_messages/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
BDEPEND="virtual/pkgconfig"
DEPEND="net-libs/toxext"
RDEPEND="${DEPEND}"
src_prepare() {
cmake_src_prepare
sed -i 's/-Werror//' CMakeLists.txt || die
}