You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-mail/public-inbox/public-inbox-1.9.0.ebuild

39 lines
824 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit perl-module
DESCRIPTION="An archives-first approach to mailing lists"
HOMEPAGE="https://public-inbox.org"
SRC_URI="https://public-inbox.org/public-inbox.git/snapshot/${P}.tar.gz"
LICENSE="AGPL-3+"
SLOT="0"
KEYWORDS="~amd64"
# in order of mention in INSTALL.html, going more for feature completeness
# than for minimal footprint
RDEPEND="
dev-perl/BSD-Resource
dev-perl/DBD-SQLite
dev-perl/Email-Address-XS
dev-perl/Inline-C
dev-perl/Linux-Inotify2
dev-perl/Mail-IMAPClient
dev-perl/Net-Server
dev-perl/Parse-RecDescent
dev-perl/Plack
dev-perl/Search-Xapian
dev-perl/TimeDate
dev-perl/URI
dev-vcs/git
net-misc/curl
virtual/mta
"
BDEPEND="
${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
"