You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-mail/qlogtools/qlogtools-3.1-r1.ebuild

42 lines
966 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Qmail Log processing tools"
HOMEPAGE="http://untroubled.org/qlogtools/"
SRC_URI="http://untroubled.org/qlogtools/archive/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
DEPEND=""
RDEPEND="!app-text/multitail"
PATCHES=(
"${FILESDIR}"/qlogtools-3.1-errno.patch
"${FILESDIR}"/qlogtools-3.1-fix-implicit-decl.patch
"${FILESDIR}"/qlogtools-3.1-fix-glibc-2-33.patch
)
src_configure() {
echo "$(tc-getCC) ${CFLAGS}" > conf-cc
echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
echo "${D}/usr/bin" > conf-bin
echo "${D}/usr/share/man/" > conf-man
}
src_install() {
dodir /usr/bin /usr/share/man/
./installer || die "Installer failed"
dodoc ANNOUNCEMENT FILES NEWS README TARGETS VERSION
}
pkg_postinst() {
elog "Please see /usr/share/doc/${PF}/README for configuration information"
}