You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/bird/bird-2.0.7.ebuild

41 lines
820 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 & IPv6"
HOMEPAGE="http://bird.network.cz"
SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~x86 ~x64-macos"
IUSE="+client debug"
RDEPEND="client? ( sys-libs/ncurses )
client? ( sys-libs/readline )"
DEPEND="app-alternatives/lex
app-alternatives/yacc
sys-devel/m4"
PATCHES=(
"${FILESDIR}/${P}-gcc10.patch"
)
src_configure() {
econf \
--localstatedir="${EPREFIX}/var" \
$(use_enable client) \
$(use_enable debug)
}
src_install() {
if use client; then
dobin birdc
fi
dobin birdcl
dosbin bird
newinitd "${FILESDIR}/initd-${PN}-2" bird
dodoc doc/bird.conf.example
}