You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/gns3-gui/gns3-gui-2.2.44.1.ebuild

41 lines
1.0 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{11..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 virtualx xdg
DESCRIPTION="Graphical Network Simulator"
HOMEPAGE="https://www.gns3.com https://github.com/GNS3/gns3-gui"
SRC_URI="https://github.com/GNS3/gns3-gui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
#net-misc/gns3-server version should always match gns3-gui version
RDEPEND="
>=dev-python/distro-1.8.0[${PYTHON_USEDEP}]
>=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
>=dev-python/psutil-5.9.6[${PYTHON_USEDEP}]
>=dev-python/sentry-sdk-1.34.0[${PYTHON_USEDEP}]
~net-misc/gns3-server-${PV}[${PYTHON_USEDEP}]
dev-python/PyQt5[gui,network,svg,websockets,widgets,${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
src_prepare() {
default
# newer python packages are fine
sed -i -e 's/[<>=].*//' requirements.txt || die
}
src_test() {
virtx distutils-r1_src_test
}