You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/mcproxy/mcproxy-1.1.1-r2.ebuild

60 lines
1.1 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit linux-info qmake-utils systemd
DESCRIPTION="A multicast proxy for IGMP/MLD"
HOMEPAGE="https://mcproxy.realmv6.org/ https://github.com/mcproxy/mcproxy"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${P}/${PN}"
KEYWORDS="amd64 x86"
LICENSE="GPL-2+"
SLOT="0"
IUSE="doc"
DEPEND="
dev-qt/qtcore:5
doc? ( app-text/doxygen )
"
PATCHES=(
"${FILESDIR}/${P}-clang.patch"
"${FILESDIR}/${P}-fix-checksum-calculation.patch"
)
CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
src_prepare() {
# Change install path from '/usr/local/bin' to '/usr/bin'
sed -e 's/local//' -i mcproxy.pro || die
default
}
src_configure() {
eqmake5
}
src_compile() {
default
use doc && emake doc
}
src_install() {
emake INSTALL_ROOT="${ED}" install
insinto /etc
doins mcproxy.conf
newinitd "${FILESDIR}"/mcproxy.initd mcproxy
systemd_dounit "${FILESDIR}"/mcproxy.service
newconfd "${FILESDIR}"/mcproxy.confd mcproxy
use doc && dodoc -r ../docs/.
}