You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/passt/passt-2024.04.05.ebuild

41 lines
842 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
HOMEPAGE="https://passt.top/"
RELEASE_COMMIT="954589b"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="git://passt.top/passt"
else
SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
KEYWORDS="~amd64 ~arm64 ~riscv"
fi
LICENSE="BSD GPL-2+"
SLOT="0"
IUSE="static"
PATCHES=(
"${FILESDIR}"/Makefile-2024.03.20.patch
)
src_prepare() {
default
tc-export CC
}
src_compile() {
[[ ${PV} != 9999* ]] && export VERSION="${PV}"
export prefix="${EPREFIX}/usr" docdir="${EPREFIX}/usr/share/doc/${P}"
emake $(usev static)
}