You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/secpanel/secpanel-0.6.1-r1.ebuild

51 lines
1.2 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Graphical frontend for managing and running SSH and SCP connections"
HOMEPAGE="https://themediahost.de/secpanel/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 sparc x86"
IUSE="gif"
DEPEND="!gif? ( virtual/imagemagick-tools )"
RDEPEND="dev-lang/tk
virtual/ssh"
S=${WORKDIR}/usr/local
src_prepare() {
# install arch indep stuff in /usr/share instead of /usr/lib*
sed -i -e '/set libdir/s:../lib:../share:' bin/secpanel || die
# fix the version
sed -i -e "/set spversion/s:0.6.0:${PV}:" bin/secpanel || die
# optionally remove gifs...
if ! use gif; then
einfo "Setting secpanel to use PPM images"
sed -i -e 's/\.gif/\.ppm/g' bin/secpanel || die
einfo "Converting all GIF images to PPM format..."
for i in $(find lib/secpanel/images -name "*.gif") ; do
einfo "convert ${i} => ${i//.gif/.ppm}"
convert "${i}" "ppm:${i//.gif/.ppm}" || die
rm -v "${i}" || die
done
fi
eapply_user
}
src_install() {
dobin bin/secpanel
insinto /usr/share/secpanel
doins -r lib/secpanel/{*.{tcl,config,profile,wait,txt,sh},images,spdistkey}
}