You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/ser2net/ser2net-2.10.0-r1.ebuild

31 lines
633 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Serial To Network Proxy"
SRC_URI="https://downloads.sourceforge.net/ser2net/${P}.tar.gz"
HOMEPAGE="https://sourceforge.net/projects/ser2net"
KEYWORDS="amd64 ppc x86"
SLOT="0"
LICENSE="GPL-2"
IUSE="tcpd"
DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
RDEPEND="${DEPEND}"
src_configure() {
econf $(use_with tcpd tcp-wrappers) --with-uucp-locking
}
src_install() {
default
insinto /etc
newins ${PN}.conf ${PN}.conf.dist
newinitd "${FILESDIR}/${PN}.initd" ${PN}
newconfd "${FILESDIR}/${PN}.confd" ${PN}
}