You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/wput/wput-0.6.2.ebuild

36 lines
854 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Tiny program like wget, to upload files/whole directories via FTP"
HOMEPAGE="https://wput.sourceforge.net/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tgz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86"
IUSE="debug nls ssl"
BDEPEND="nls? ( sys-devel/gettext )"
RDEPEND="ssl? ( net-libs/gnutls )"
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-0.6.2-respect-destdir.patch"
"${FILESDIR}/${PN}-0.6-respectldflags.patch"
"${FILESDIR}/${PN}-fix-crash.patch"
"${FILESDIR}/${PN}-0.6.2-fno-common.patch"
)
DOCS=( ChangeLog INSTALL TODO )
src_configure() {
local myconf="--enable-g-switch=no"
use debug && myconf="--enable-memdbg=yes"
econf \
$(use_enable nls) \
$(use_with ssl) \
"${myconf}"
}