You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-print/cups-bjnp/cups-bjnp-2.0.3-r1.ebuild

33 lines
612 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit autotools
DESCRIPTION="CUPS backend for canon printers using proprietary USB over IP BJNP protocol"
HOMEPAGE="https://sourceforge.net/projects/cups-bjnp/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
DEPEND="net-print/cups"
RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-2.0.3-configure-clang16.patch
)
src_prepare() {
default
# Clang 16
eautoreconf
}
src_configure() {
econf --disable-Werror
}