You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-print/libinklevel/libinklevel-0.9.3.ebuild

44 lines
808 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit autotools
MY_P="${P/_/}"
DESCRIPTION="A library to get the ink level of your printer"
HOMEPAGE="http://libinklevel.sourceforge.net/"
SRC_URI="https://downloads.sourceforge.net/libinklevel/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="debug"
DEPEND=">=sys-libs/libieee1284-0.2.11
virtual/libusb:1"
RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-0.9.2-autoconf-2.70.patch
)
src_prepare() {
default
sed -i -e "/^dist_doc_DATA/d" Makefile.am \
|| die "Failed to disable installation of docs"
eautoreconf
}
src_configure() {
econf $(use_enable debug)
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}