You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-vpn/tinc/tinc-1.0.36.ebuild

43 lines
1008 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit systemd
DESCRIPTION="tinc is an easy to configure VPN implementation"
HOMEPAGE="https://www.tinc-vpn.org/"
SRC_URI="https://www.tinc-vpn.org/packages/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="+lzo uml vde +zlib"
DEPEND="
dev-libs/openssl:0=
lzo? ( dev-libs/lzo:2 )
zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}
vde? ( net-misc/vde )"
src_configure() {
econf \
--enable-jumbograms \
--disable-tunemu \
$(use_enable lzo) \
$(use_enable uml) \
$(use_enable vde) \
$(use_enable zlib)
}
src_install() {
emake DESTDIR="${D}" install
dodir /etc/tinc
dodoc AUTHORS NEWS README THANKS
doconfd "${FILESDIR}"/tinc.networks
newconfd "${FILESDIR}"/tincd.conf tincd
newinitd "${FILESDIR}"/tincd-r1 tincd
systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
}