You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-wireless/soapyremote/soapyremote-9999.ebuild

30 lines
663 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
DESCRIPTION="Soapy SDR remote module"
HOMEPAGE="https://github.com/pothosware/SoapyRemote"
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/pothosware/SoapyRemote.git"
EGIT_CLONE_TYPE="shallow"
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/pothosware/SoapyRemote/archive/soapy-remote-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/SoapyRemote-soapy-remote-"${PV}"
fi
LICENSE="Boost-1.0"
SLOT="0"
IUSE=""
REQUIRED_USE=""
RDEPEND="net-wireless/soapysdr
net-dns/avahi"
DEPEND="${RDEPEND}"