You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-wireless/suwidgets/suwidgets-0.3.0.ebuild

42 lines
884 B

# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit qmake-utils
DESCRIPTION="graphical library containing all SigDigger's custom widgets"
HOMEPAGE="https://github.com/BatchDrake/SuWidgets"
SRC_URI="https://github.com/BatchDrake/SuWidgets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
media-libs/libglvnd
"
RDEPEND="${DEPEND}"
BDEPEND=""
S="${WORKDIR}/SuWidgets-${PV}"
src_prepare() {
sed -i '/^#include <QPainter>/i #include <QPainterPath>' Waveform.cpp Waterfall.cpp \
Transition.cpp SymView.cpp QVerticalLabel.cpp LCD.cpp Histogram.cpp \
Constellation.cpp ColorChooserButton.cpp
default
}
src_configure() {
eqmake5 SuWidgetsLib.pro
}
src_install() {
INSTALL_ROOT="${ED}" emake install
}