You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-calculators/pcalc/pcalc-4.ebuild

26 lines
568 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="the programmers calculator"
HOMEPAGE="https://github.com/vapier/pcalc"
SRC_URI="https://downloads.sourceforge.net/pcalc/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~s390 sparc ~x86 ~amd64-linux ~x86-linux"
BDEPEND="app-alternatives/lex"
src_prepare() {
default
sed -i -e "s:/usr:${EPREFIX}/usr:g" Makefile || die
}
src_configure() {
tc-export CC
}