You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-calculators/qalculate-qt/qalculate-qt-4.8.0.ebuild

36 lines
712 B

# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# Bump with sci-libs/libqalculate and sci-calculators/qalculate-gtk!
inherit qmake-utils
DESCRIPTION="Qt-based UI for libqalculate"
HOMEPAGE="https://github.com/Qalculate/qalculate-qt"
SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
DEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
>=sci-libs/libqalculate-${PV}
"
RDEPEND="${DEPEND}"
BDEPEND="dev-qt/linguist-tools:5"
src_prepare() {
default
eqmake5 PREFIX="${EPREFIX}/usr"
}
src_install() {
emake INSTALL_ROOT="${ED}" install
}