You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-chemistry/surf/surf-1.0.ebuild

33 lines
585 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Solvent accesible Surface calculator"
HOMEPAGE="http://www.ks.uiuc.edu/"
SRC_URI="http://www.ks.uiuc.edu/Research/vmd/extsrcs/surf.tar.Z -> ${P}.tar.Z"
LICENSE="SURF"
SLOT="0"
KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
RDEPEND="!www-client/surf"
S="${WORKDIR}"
PATCHES=(
"${FILESDIR}"/${P}-makefile.patch
"${FILESDIR}"/${P}-Wreturn-type.patch
)
src_configure() {
tc-export CC
}
src_install() {
dobin surf
einstalldocs
}