You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/geos/geos-3.11.0.ebuild

47 lines
935 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
DESCRIPTION="Geometry engine library for Geographic Information Systems"
HOMEPAGE="https://libgeos.org/"
SRC_URI="https://download.osgeo.org/geos/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~ia64 ~ppc ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="doc test"
RESTRICT="!test? ( test )"
BDEPEND="doc? ( app-text/doxygen )"
src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)
-DBUILD_TESTING=$(usex test)
-DUSE_CCACHE=OFF
# bug #709368
$(usex arm '-DDISABLE_GEOS_INLINE=ON' '')
)
cmake_src_configure
}
src_compile() {
cmake_src_compile
use doc && cmake_src_compile docs
}
src_install() {
cmake_src_install
if use doc ; then
HTML_DOCS=( "${BUILD_DIR}"/doxygen/doxygen_docs/html/. )
einstalldocs
fi
}