You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild

58 lines
1.2 KiB

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake toolchain-funcs
DESCRIPTION="Numerical linear algebra software package"
HOMEPAGE="https://ginkgo-project.github.io/"
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/ginkgo-project/ginkgo"
inherit git-r3
else
SRC_URI="https://github.com/${PN}-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="BSD-with-attribution"
SLOT="0"
IUSE="cuda hwloc +openmp"
RDEPEND="
cuda? ( dev-util/nvidia-cuda-toolkit )
hwloc? ( sys-apps/hwloc:= )
"
DEPEND="${RDEPEND}"
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
sed -i \
-e "s#\"lib\"#\"$(get_libdir)\"#g" \
-e "s#\"lib/#\"$(get_libdir)/#g" \
cmake/install_helpers.cmake || die "sed failed"
cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DGINKGO_DEVEL_TOOLS=OFF
-DGINKGO_BUILD_TESTS=OFF
-DGINKGO_BUILD_BENCHMARKS=OFF
-DGINKGO_BUILD_REFERENCE=ON
-DGINKGO_BUILD_CUDA=$(usex cuda)
-DGINKGO_BUILD_HWLOC=$(usex hwloc)
-DGINKGO_BUILD_OMP=$(usex openmp)
)
cmake_src_configure
}