You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-mathematics/lrcalc/lrcalc-2.1.ebuild

24 lines
541 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Littlewood-Richardson Calculator"
HOMEPAGE="https://sites.math.rutgers.edu/~asbuch/lrcalc/"
SRC_URI="https://sites.math.rutgers.edu/~asbuch/lrcalc/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0/2"
KEYWORDS="amd64 ~x86 ~ppc-macos ~x64-macos"
IUSE="static-libs test"
RESTRICT="!test? ( test )"
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}