You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-visualization/fig2sxd/fig2sxd-0.22.1.ebuild

33 lines
690 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="Utility to convert files in xfig format to OpenOffice.org Draw format"
LICENSE="GPL-2"
HOMEPAGE="https://sourceforge.net/projects/fig2sxd"
SRC_URI="https://downloads.sourceforge.net/${PN}/${PN}_${PV}.orig.tar.gz"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
RDEPEND="sys-libs/zlib"
DEPEND="${RDEPEND}"
DOCS=( changelog )
PATCHES=( "${FILESDIR}"/${PN}-0.20-phony-check.patch )
src_compile() {
emake CXXFLAGS="${CXXFLAGS}" CXX="$(tc-getCXX)"
}
src_install() {
dobin ${PN}
doman ${PN}.1
einstalldocs
}