You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sec-policy/apparmor-profiles/apparmor-profiles-9999.ebuild

38 lines
731 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit git-r3
DESCRIPTION="A collection of profiles for the AppArmor application security system"
HOMEPAGE="https://gitlab.com/apparmor/apparmor/wikis/home"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="minimal vanilla"
RESTRICT="test"
S=${WORKDIR}/${P}/profiles
pkg_setup() {
if use vanilla; then
EGIT_REPO_URI="https://gitlab.com/apparmor/apparmor.git"
EGIT_BRANCH="master"
else
EGIT_REPO_URI="https://github.com/kensington/apparmor.git"
EGIT_BRANCH="gentoo"
fi
}
src_install() {
if use minimal ; then
insinto /etc/apparmor.d
doins -r apparmor.d/{abi,abstractions,tunables}
else
default
fi
}