You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-auth/pam_u2f/pam_u2f-1.1.1.ebuild

35 lines
703 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools flag-o-matic pam
DESCRIPTION="PAM module for FIDO2 and U2F keys"
HOMEPAGE="https://github.com/Yubico/pam-u2f"
SRC_URI="https://developers.yubico.com/${PN/_/-}/Releases/${P}.tar.gz"
LICENSE="BSD ISC"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug"
DEPEND="
dev-libs/libfido2:=
dev-libs/openssl:=
sys-libs/pam"
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${PN}-1.1.1-fix-Makefile.patch )
src_prepare() {
default
eautoreconf
}
src_configure() {
use debug || append-cppflags -UDEBUG_PAM -UPAM_DEBUG
econf --with-pam-dir=$(getpam_mod_dir)
}