You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-cluster/kubeadm/kubeadm-1.29.1.ebuild

36 lines
982 B

# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit bash-completion-r1 go-module
DESCRIPTION="CLI to Easily bootstrap a secure Kubernetes cluster"
HOMEPAGE="https://kubernetes.io"
SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm64"
IUSE="hardened selinux"
BDEPEND=">=dev-lang/go-1.20"
RDEPEND="app-containers/cri-tools
selinux? ( sec-policy/selinux-kubernetes )"
RESTRICT+=" test"
S="${WORKDIR}/kubernetes-${PV}"
src_compile() {
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" FORCE_HOST_GO=yes \
emake -j1 GOFLAGS=-v GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
}
src_install() {
dobin _output/bin/${PN}
_output/bin/${PN} completion bash > ${PN}.bash || die
_output/bin/${PN} completion zsh > ${PN}.zsh || die
newbashcomp ${PN}.bash ${PN}
insinto /usr/share/zsh/site-functions
newins ${PN}.zsh _${PN}
}