You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-cluster/ucx/ucx-1.9.0.ebuild

32 lines
608 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Unified Communication X"
HOMEPAGE="https://www.openucx.org"
SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+numa +openmp"
RDEPEND="
sys-libs/binutils-libs:=
numa? ( sys-process/numactl )
"
DEPEND="${RDEPEND}"
src_configure() {
BASE_CFLAGS="" \
econf \
--disable-compiler-opt \
$(use_enable numa) \
$(use_enable openmp)
}
src_compile() {
BASE_CFLAGS="" emake
}