You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-19.e...

38 lines
741 B

# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit multilib
DESCRIPTION="Symlinks to use LLD on binutils-free system"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
S=${WORKDIR}
LICENSE="public-domain"
SLOT="${PV}"
IUSE="multilib-symlinks +native-symlinks"
RDEPEND="
sys-devel/lld:${SLOT}
"
src_install() {
use native-symlinks || return
local chosts=( "${CHOST}" )
if use multilib-symlinks; then
local abi
for abi in $(get_all_abis); do
chosts+=( "$(get_abi_CHOST "${abi}")" )
done
fi
local dest=/usr/lib/llvm/${SLOT}/bin
dodir "${dest}"
dosym ld.lld "${dest}/ld"
for chost in "${chosts[@]}"; do
dosym ld.lld "${dest}/${chost}-ld"
done
}