You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-devel/llvmgold/llvmgold-19.ebuild

23 lines
508 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="LLVMgold plugin symlink for autoloading"
HOMEPAGE="https://llvm.org/"
S=${WORKDIR}
LICENSE="public-domain"
SLOT="0"
RDEPEND="
sys-devel/llvm:${PV}[binutils-plugin]
!sys-devel/llvm:0
"
src_install() {
dodir "/usr/${CHOST}/binutils-bin/lib/bfd-plugins"
dosym "../../../../lib/llvm/${PV}/$(get_libdir)/LLVMgold.so" \
"/usr/${CHOST}/binutils-bin/lib/bfd-plugins/LLVMgold.so"
}