You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-fs/fuse-exfat/fuse-exfat-1.4.0.ebuild

25 lines
717 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="exFAT filesystem FUSE module"
HOMEPAGE="https://github.com/relan/exfat"
SRC_URI="https://github.com/relan/exfat/releases/download/v${PV}/${P}.tar.gz"
# COPYING is GPL-2 but ChangeLog says "Relicensed the project from GPLv3+ to GPLv2+"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~x86-linux"
IUSE="suid"
RDEPEND="sys-fs/fuse:3"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_install() {
default
use suid && fperms u+s /usr/sbin/mount.exfat-fuse
dosym mount.exfat-fuse.8 /usr/share/man/man8/mount.exfat.8
}