You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-fs/ncdu/ncdu-2.3.ebuild

130 lines
2.9 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit verify-sig edo
DESCRIPTION="NCurses Disk Usage"
HOMEPAGE="https://dev.yorhel.nl/ncdu"
SRC_URI="
https://dev.yorhel.nl/download/${P}.tar.gz
verify-sig? ( https://dev.yorhel.nl/download/${P}.tar.gz.asc )
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
EZIG_MIN="0.11"
EZIG_MAX_EXCLUSIVE="0.12"
DEPEND="sys-libs/ncurses:=[unicode(+)]"
RDEPEND="${DEPEND}"
BDEPEND="
|| ( dev-lang/zig:${EZIG_MIN} dev-lang/zig-bin:${EZIG_MIN} )
virtual/pkgconfig
dev-lang/perl
verify-sig? ( sec-keys/openpgp-keys-yorhel )
"
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/yoranheling.asc
# see https://github.com/ziglang/zig/issues/3382
# For now, Zig doesn't support CFLAGS/LDFLAGS/etc.
QA_FLAGS_IGNORED="usr/bin/ncdu"
# Many thanks to Florian Schmaus (Flowdalic)!
# Adapted from https://github.com/gentoo/gentoo/pull/28986
# Set the EZIG environment variable.
zig-set_EZIG() {
[[ -n ${EZIG} ]] && return
if [[ -n ${EZIG_OVERWRITE} ]]; then
export EZIG="${EZIG_OVERWRITE}"
return
fi
local candidate selected selected_ver ver
for candidate in "${BROOT}"/usr/bin/zig-*; do
if [[ ! -L ${candidate} || ${candidate} != */zig?(-bin)-+([0-9.]) ]]; then
continue
fi
ver=${candidate##*-}
if [[ -n ${EZIG_EXACT_VER} ]]; then
ver_test "${ver}" -ne "${EZIG_EXACT_VER}" && continue
selected="${candidate}"
selected_ver="${ver}"
break
fi
if [[ -n ${EZIG_MIN} ]] \
&& ver_test "${ver}" -lt "${EZIG_MIN}"; then
# Candidate does not satisfy EZIG_MIN condition.
continue
fi
if [[ -n ${EZIG_MAX_EXCLUSIVE} ]] \
&& ver_test "${ver}" -ge "${EZIG_MAX_EXCLUSIVE}"; then
# Candidate does not satisfy EZIG_MAX_EXCLUSIVE condition.
continue
fi
if [[ -n ${selected_ver} ]] \
&& ver_test "${selected_ver}" -gt "${ver}"; then
# Candidate is older than the currently selected candidate.
continue
fi
selected="${candidate}"
selected_ver="${ver}"
done
if [[ -z ${selected} ]]; then
die "Could not find (suitable) zig installation in ${BROOT}/usr/bin"
fi
export EZIG="${selected}"
export EZIG_VER="${selected_ver}"
}
# Invoke zig with the optionally provided arguments.
ezig() {
zig-set_EZIG
# Unfortunately, we cannot add more args here, since syntax is different
# for every subcommands. Yes, even target/cpu :( f.i. :
# -target/-mcpu for zig build-exe vs -Dtarget/-Dcpu for zig build-
# -OReleaseSafe for zig build-exe vs -DReleaseSafe for zig build
# (or even none, if hardcoded by upstream so choice is -Drelease=true/false)
# Ofc we can patch this, but still...
edo "${EZIG}" "${@}"
}
src_unpack() {
if use verify-sig; then
verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.asc}
fi
default
}
src_configure() {
zig-set_EZIG
export ZIG=${EZIG}
}
src_test() {
ezig build test -Doptimize=ReleaseFast
}
src_install() {
emake PREFIX="${ED}"/usr install
dodoc README.md ChangeLog
}