You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-libs/libieee1284/libieee1284-0.2.11-r8.ebuild

50 lines
945 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
inherit autotools multilib-minimal
DESCRIPTION="Library to query devices using IEEE1284"
HOMEPAGE="http://cyberelk.net/tim/software/libieee1284/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ppc x86"
IUSE="doc static-libs"
BDEPEND="doc? (
app-text/docbook-sgml-utils
>=app-text/docbook-sgml-dtd-4.1
app-text/docbook-dsssl-stylesheets
dev-perl/XML-RegExp
)"
src_prepare() {
default
mv configure.{in,ac} || die
eautoreconf
}
multilib_src_configure() {
local myeconfargs=(
--enable-shared
--without-python
$(use_enable static-libs static)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
einstalldocs
dodoc doc/interface*
if ! use static-libs; then
find "${ED}" -name '*.la' -delete || die
fi
}