You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-power/powerstat/powerstat-0.02.27.ebuild

28 lines
624 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Laptop power measuring tool"
HOMEPAGE="https://launchpad.net/ubuntu/+source/powerstat https://github.com/ColinIanKing/powerstat"
SRC_URI="https://github.com/ColinIanKing/${PN}/archive/V${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
src_prepare() {
default
# Don't compress manpages
sed -i -e '/install:/s/ powerstat.8.gz//' \
-e '/cp powerstat.8/s/.gz//' \
Makefile || die "sed failed"
}
src_compile() {
emake CC="$(tc-getCC)"
}