You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/www-apps/mirmon/mirmon-2.11-r2.ebuild

47 lines
1022 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit webapp
WEBAPP_MANUAL_SLOT="yes"
DESCRIPTION="Simple webapp to monitor the status of mirrors"
# The author has passed away: https://www.apache.org/memorials/henk_penning.html
HOMEPAGE="http://www2.projects.science.uu.nl/csg/mirmon/mirmon.html"
SRC_URI="mirror://debian/pool/main/m/${PN}/${PN}_${PV}.orig.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND=">=dev-lang/perl-5.8.5-r2:0"
RDEPEND="${DEPEND}
dev-perl/File-Tempdir
dev-perl/Socket6"
PATCHES=(
"${FILESDIR}/2.11-Add-ipv6-monitor-support-to-mirmon.patch"
"${FILESDIR}/2.11-Fix-options.patch"
)
src_install() {
# Don't install empty dirs
MY_CGIBINDIR=""
MY_ICONSDIR=""
MY_ERRORSDIR=""
webapp_src_preinst
for file in mirmon.html mirmon.txt; do
dodoc ${file}
rm -f ${file}
done
cp -R icons "${D}"/${MY_HTDOCSDIR}
rm -rf icons
cp -R . "${D}"/${MY_HOSTROOTDIR}
webapp_src_install
}