You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-apps/xdpyinfo/xdpyinfo-1.3.4.ebuild

39 lines
800 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
XORG_TARBALL_SUFFIX="xz"
inherit xorg-3
DESCRIPTION="Display information utility for X"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="dga dmx xinerama"
RDEPEND="
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXext
x11-libs/libXi
x11-libs/libXrender
x11-libs/libXtst
x11-libs/libXxf86vm
x11-libs/libxcb
dga? ( x11-libs/libXxf86dga )
dmx? ( x11-libs/libdmx )
xinerama? ( x11-libs/libXinerama )
"
DEPEND="${RDEPEND}
x11-base/xorg-proto
"
src_configure() {
local XORG_CONFIGURE_OPTIONS=(
--without-xf86misc
$(use_with dga)
$(use_with dmx)
$(use_with xinerama)
)
xorg-3_src_configure
}