You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-apps/xsm/xsm-1.0.6.ebuild

30 lines
736 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
XORG_TARBALL_SUFFIX="xz"
inherit xorg-3
DESCRIPTION="X Session Manager"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
RDEPEND="x11-libs/libXaw
x11-libs/libX11
x11-libs/libXt
x11-libs/libICE
x11-libs/libSM"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
pkg_setup() {
# (#158056) /usr/$(get_libdir)/X11/xsm could be a symlink
local XSMPATH="${EROOT}/usr/$(get_libdir)/X11/xsm"
if [[ -L ${XSMPATH} ]]; then
einfo "Removing symlink ${XSMPATH}"
rm -f ${XSMPATH} || die "failed to remove symlink ${XSMPATH}"
fi
xorg-3_pkg_setup
}