You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-base/xorg-proto/xorg-proto-2024.1.ebuild

52 lines
1.1 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
MY_PN="${PN/xorg-/xorg}"
MY_P="${MY_PN}-${PV}"
EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
inherit ${GIT_ECLASS} meson python-any-r1
DESCRIPTION="X.Org combined protocol headers"
HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
if [[ ${PV} != 9999* ]]; then
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.xz"
S="${WORKDIR}/${MY_P}"
fi
LICENSE="MIT"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
BDEPEND="
test? (
$(python_gen_any_dep '
dev-python/libevdev[${PYTHON_USEDEP}]
')
)
"
python_check_deps() {
python_has_version "dev-python/libevdev[${PYTHON_USEDEP}]"
}
pkg_setup() {
use test && python-any-r1_pkg_setup
}
src_install() {
meson_src_install
mv "${ED}"/usr/share/doc/{xorgproto,${P}} || die
}